How to do firmware updates

dgingeridgingeri Member Posts: 8
I am having a hell of a time trying to find any instructions on how to do a firmware update. I have been all over the app, and I see nothing about updating the firmware. How do I do it?

Comments

  • dgingeridgingeri Member Posts: 8
    I am not finding any instructions on that forum post.
  • Look at the post by @ericsr‌ and @Springs‌. You can ssh into AP and issue fw update.
  • dgingeridgingeri Member Posts: 8
    ok, I finally pieced things together. These instructions need to be in one place.
  • ericsrericsr Member Posts: 457
    dgingeri said:

    ok, I finally pieced things together. These instructions need to be in one place.

    Technically this should happen automatically and you get notified in app of the update. These instructions are to get around this. If you have problems, please let us know so new can help.
  • dgingeridgingeri Member Posts: 8
    edited January 2015
    ericsr said:

    Technically this should happen automatically and you get notified in app of the update. These instructions are to get around this. If you have problems, please let us know so new can help.

    However, if the AP is configured with a static IP address from the Harmony app, like mine was, there is no way to set the DNS server, so the updates won't happen. Trying to update the firmware from SSH just resulted in an immediate error about the server timing out, which wasn't accurate to the problem. In fact, the DNS lookup failed because there was no DNS server set.

    I had to SSH in, which was more difficult than it had to be because the username wasn't easily found, and set the update server to the IP address provided in this thread, in order to get the update to occur. Once I had the web interface, I was able to set the DNS server addresses. Several days of searching finally resulted in getting it done. Really, specific instructions need to be written up.

    If you have set your AP to a static IP address, the AP may not be able to get firmware updates. If this is the case, you can try these steps:
    1. SSH into the AP using a terminal program like PuTTY at the preset IP address (username: xclaim-mfg default password: XXX Password may be set to the password configured by you when setting up your Harmony app.)
    2. type "fw set host 23.236.53.216" and hit enter
    3. type "fw update" and hit enter
    4. wait for reboot (the terminal program will disconnect, please wait approximately 2 minutes for the AP to boot back up.)
    5. try the web interface at the preset IP address. If it comes up, you are done. If not, try to access it again through the SSH terminal program as listed in step 1 and type in the command "reboot"

    Does that look good?
  • ericsrericsr Member Posts: 457
    edited January 2015
    dgingeri said:

    ericsr said:

    Technically this should happen automatically and you get notified in app of the update. These instructions are to get around this. If you have problems, please let us know so new can help.

    However, if the AP is configured with a static IP address from the Harmony app, like mine was, there is no way to set the DNS server, so the updates won't happen. Trying to update the firmware from SSH just resulted in an immediate error about the server timing out, which wasn't accurate to the problem. In fact, the DNS lookup failed because there was no DNS server set.

    I had to SSH in, which was more difficult than it had to be because the username wasn't easily found, and set the update server to the IP address provided in this thread, in order to get the update to occur. Once I had the web interface, I was able to set the DNS server addresses. Several days of searching finally resulted in getting it done. Really, specific instructions need to be written up.

    If you have set your AP to a static IP address, the AP may not be able to get firmware updates. If this is the case, you can try these steps:
    1. SSH into the AP using a terminal program like PuTTY at the preset IP address (username: xclaim-mfg default password: XXX Password may be set to the password configured by you when setting up your Harmony app.)
    2. type "fw set host 23.236.53.216" and hit enter
    3. type "fw update" and hit enter
    4. wait for reboot (the terminal program will disconnect, please wait approximately 2 minutes for the AP to boot back up.)
    5. try the web interface at the preset IP address. If it comes up, you are done. If not, try to access it again through the SSH terminal program as listed in step 1 and type in the command "reboot"

    Does that look good?
    As explained in other responses, I WOULD advise against setting the host to the IP address, unless you are changing it back immediately.
  • dgingeridgingeri Member Posts: 8
    I didn't see instructions on how to change it back. So, mine is still set to the IP.
  • ericsrericsr Member Posts: 457
    fw set host update.xclaimwireless.com
  • ericsrericsr Member Posts: 457
    dgingeri said:

    ok, how's this for instructions:

    If you have set your AP to a static IP address, the AP may not be able to get firmware updates. If this is the case, you can try these steps:
    1. SSH into the AP using a terminal program like PuTTY at the preset IP address (username: xclaim-mfg default password: XXX Password may be set to the password configured by you when setting up your Harmony app.)
    2. type "fw set host 23.236.53.216" and hit enter
    3. type "fw update" and hit enter
    4. wait for reboot (the terminal program will disconnect, please wait approximately 2 minutes for the AP to boot back up.)
    5. try the web interface at the preset IP address. If it comes up, you are done. If not, try to access it again through the SSH terminal program as listed in step 1 and type in the command "reboot"
    6. after confirming that the web interface works, connect to the AP by SSH once again and login
    7. type the command "fw set host update.xclaimwireless.com" and hit enter, then disconnect from the AP. Everything should be working properly again at this point.

    This is the beauty of forums and why I appreciate the community. This type of interaction is critical to our success. Thanks for helping out.
  • dgingeridgingeri Member Posts: 8
    One more amendment, I needed to correct the default password:

    If you have set your AP to a static IP address, the AP may not be able to get firmware updates. If this is the case, you can try these steps:
    1. SSH into the AP using a terminal program like PuTTY at the preset IP address (username: xclaim-mfg default password: mfg-admin12 Password may be set to the password configured by you when setting up your Harmony app.)
    2. type "fw set host 23.236.53.216" and hit enter
    3. type "fw update" and hit enter
    4. wait for reboot (the terminal program will disconnect, please wait approximately 2 minutes for the AP to boot back up.)
    5. try the web interface at the preset IP address. If it comes up, you are done. If not, try to access it again through the SSH terminal program as listed in step 1 and type in the command "reboot"
    6. after confirming that the web interface works, connect to the AP by SSH once again and login
    7. type the command "fw set host update.xclaimwireless.com" and hit enter, then disconnect from the AP. Everything should be working properly again at this point.
  • dhaysleydhaysley Member Posts: 6
    I can no longer use the harmony app because it cannot find the AP and I do not want to factory reset. Following the instructions above it says the file is too large. Any ideas how to increase the allowed size?

    xclaim : fw update
    fw: Updating rcks_wlan.main ...

    Image1 FW check ...

    MD5 = 3DDC921016C3C8BCB4E996CEF7DCBB76
    FW=0 not MAIN or BKUP
    mtd(rcks_wlan.main) size=1245184 < 8740864
    New main firmware size=8740864 is too big
    ** new firmware too big
    **fw(24127) : File too large
  • ericsrericsr Member Posts: 457
    dhaysley said:

    I can no longer use the harmony app because it cannot find the AP and I do not want to factory reset. Following the instructions above it says the file is too large. Any ideas how to increase the allowed size?

    xclaim : fw update
    fw: Updating rcks_wlan.main ...

    Image1 FW check ...

    MD5 = 3DDC921016C3C8BCB4E996CEF7DCBB76
    FW=0 not MAIN or BKUP
    mtd(rcks_wlan.main) size=1245184 < 8740864
    New main firmware size=8740864 is too big
    ** new firmware too big
    **fw(24127) : File too large

    All you need to do is reboot the AP.
  • dhaysleydhaysley Member Posts: 6
    I have rebooted several times based on another post that I found. It does not update. What is the latest build number?

  • ericsrericsr Member Posts: 457
    edited February 2015
    Build 83. I am guessing you cannot resolve the DNS name for the update server. Up above details this.
Sign In or Register to comment.