My XI-2 AP and wired clients can all see the internet, but wired and wireless cannot ping each other

My hardware setup is as follows...

VDSL -> modem -> Router -> Gigabit switch
Gigabit switch <- XI-2 WAP
Gigabit switch <- NAS
Gigabit switch <- PC
Gigabit switch <- PS4
Gigabit switch <- Amazon Fire TV
Gigabit switch <- Roku

All wireless devices connect to the XI-2 WAP.
All devices, wired and wireless can see the Internet very well. It's

Router has the only DHCP server and all devices, wireless and wired, get an IP within the range specified in the router 192.168.1.64-253 (254 is the router)

I can ping all wired devices, including the WAP (192.168.1.94) from my PC, also wired.

The problem is the wireless devices cannot ping each other. My PC cannot ping the wireless devices either.

I thought it would be security protocols, but I created another guess network with no security and it was still the same. connection to the internet is fine, but nothing to all other devices in the network.

I think there is a setting somewhere, because this worked on my previous TP-LINK WAP.

Please, any ideas would be so very welcome. I like this xclaim box and don't want to have to compromise.

Thanks in advance.

Tagged:

Comments

  • vybhavramvybhavram Xpert, Moderator Posts: 1,063

    Hello @MichaelWT ,

    What you are noticing is expected behavior when Client Isoaltion is enabled in the WLAN.

    When client isolation is enabled for a WLAN , here is what happens:

    • The wireless devices cannot communicate with other wireless devices
    • The wireless devices cannot communicate with any wired device other the default gateway. This ensures that they have internet access.

    So what you are seeing is exactly according to design.

    In order to enable communication between wireless and wired devices , please disabled Client Isolation in the Network's settings and check.

    Hope this helps.

    Regards,
    Vybhav

  • remixedcatremixedcat Member Posts: 21

    Are your VLANs configured/tagged correctly? Also you need to make sure your switch's VLAN settings are correct as well.

Sign In or Register to comment.