Cant connect to XO-1

I am really disappointed with my new XO-1 as I can not connect to it from anything. I have tried it from Android phone (Samsung S5), Apple iPad Mini and via the web browser. The unit just does not respond, even though I can see it on the network. I have read lots of threads on here, tried everything that I can find and it still does not work.

So I have plugged it into the BT ADSL Hub, that also does the house WIFI. I connect to the 'xclaim-setup' WIFI network & connect to that on all 3 devices.

On Android I download the current version of Harmony & do the setup routine. That works OK and it says everything is fine...!!! It then scans for the AP & it is really flakey. Half the time it finds nothing. The other half it finds an AP (round circle with it's IP) but when you click on it it says 'Loading...' which lasts for 2 minutes before crashing out to the App login screen & repeating the search cycle. I have done multiple 8 second+ resets that does not appear to do anything helpful.

On iPad mini the software installs OK but the scan has never found anything.....

On the MacBook it is very flakey again. It connects maybe 1 time in 5 using:
https://192.168.1.94 (the IP found while scanning the subnet)

Trouble is that when you do get a login box it does not work with:
User: xclaim-mfg
Pass: mfg-admin12

I am amazed at how rubbish this piece of hardware is. I have installed well over 1000 switches, hubs, routers & wifi boxes in my 40 year career as an IT guy and this has to be the most stupid setup method I have ever seen.... How anybody though this would be a good idea to setup your wifi router from a phone/tablet is amazing.... Even the basic web login does not work. There is no proper instruction manual that I can find & even the retailer said 'yes it is C**P to set up but is good if you can get it working...'.

I will try reading some more but you should not have to spend a few hours going through the support forum to get a WIFI AP working. Hugely disappointed with XClaim.

Comments

  • Sorry that you are having problem with the AP.

    If the AP is set to static IP Address, AP may not get upgraded for older firmware version. You can try below mentioned steps to upgrade the AP ..

    1. SSH into the AP using a terminal program like PuTTY at the preset IP address (username: xclaim-mfg default password: mfg-admin12 Password may be set to the password configured by you when setting up your Harmony app.)
    2. type "fw set host 23.236.53.216" and hit enter
    3. type "fw update" and hit enter
    4. wait for reboot (the terminal program will disconnect, please wait approximately 2 minutes for the AP to boot back up.)
    5. try the web interface at the preset IP address. If it comes up, you are done. If not, try to access it again through the SSH terminal program as listed in step 1 and type in the command "reboot"
    6. after confirming that the web interface works, connect to the AP by SSH once again and login
    7. type the command "fw set host update.xclaimwireless.com" and hit enter, then disconnect from the AP. Everything should be working properly again at this point.

    Thanks
    Ramesh

  • dw333dw333 Member Posts: 6

    t looks like my firmware will not update:

    MacbookAir\032D:~ dwhite$ ssh 192.168.1.94
    The authenticity of host '192.168.1.94 (192.168.1.94)' can't be established.
    RSA key fingerprint is 06:fe:61:cb:d8:3b:c8:5b:b7:9e:89:31:a5:dc:7b:50.
    Are you sure you want to continue connecting (yes/no)? y
    Please type 'yes' or 'no': yes
    Warning: Permanently added '192.168.1.94' (RSA) to the list of known hosts.

    Please login: xclaim-mfg
    password :
    Copyright(C) 2005-2014 Ruckus Wireless, Inc. All Rights Reserved.

    ** Xclaim -1 Multimedia Hotzone Wireless AP: 501484302672

    rkscli: get version
    Xclaim -1 Multimedia Hotzone Wireless AP
    Version: 1.0.0.0.32
    OK
    rkscli: fw upgrade
    fw: Updating rcks_wlan.bkup ...

    Image2 FW check ...

    MD5 = 6B92FDBD6F2CA45B30E1ACEE1866E2F7
    _erase_flash: offset=0x0 count=50
    Erase Total 50 Units
    Performing Flash Erase of length 262144 at offset 0xc40000 done
    .................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................net_get_flash: Receive last block buf 4096
    net_get_flash: hdr_fsize=12988416, real_fsize=12984320
    bdSave: sizeof(bd)=0x7c, sizeof(rbd)=0xd0
    caching flash data from /dev/mtd3 [ 0x00000000 - 0x00010000 ]
    updating flash data [0x00008000 - 0x000080d0] from [0x7fef3010 - 0x7fef30e0]
    _erase_flash: offset=0x0 count=1
    Erase Total 1 Units
    Performing Flash Erase of length 262144 at offset 0x0 done
    caching flash data from /dev/mtd3 [ 0x00000000 - 0x00010000 ]
    verifying flash data [0x00008000 - 0x000080d0] from [0x7fef3010 - 0x7fef30e0]
    **fw(26947) : Completed
    rkscli: get version
    Xclaim -1 Multimedia Hotzone Wireless AP
    Version: 1.0.0.0.32
    OK

  • Hi @dw333,

    Looks like AP firmware has updated. You need to reboot the AP for the partition to swap.

    Thanks
    Ramesh

  • dw333dw333 Member Posts: 6

    I did a reboot & it upgraded to 2.0.0.0.352. Everything is working fine now:

    Please login: xclaim-mfg
    password :
    Copyright(C) 2005-2014 Xclaim Wireless, Inc. All Rights Reserved.

    ** Xo-1 / BIG WIFI. Small Business.: 501484302672

    xclaim : get version
    Xo-1 / BIG WIFI. Small Business.
    Version: 2.0.0.0.352
    Dry-Run: 0

    OK

    So the unit had a really old version of the firmware on it & it was not updating properly by rebooting like it is supposed to.

    Not very good at all but at least it is working on both the web page & the iPad

    *** If you can't connect properly then upgrade the firmware ***

  • Glad that AP is working fine now.

    Thanks
    Ramesh

  • javileshsijavileshsi Member Posts: 5

    Hi Support!

    After the following the step 1 to 4 dont acepted the password mfg-admin12

  • vybhavramvybhavram Xpert, Moderator Posts: 1,051

    Hello @javileshsi ,

    Thanks for contacting us! Have you added your AP to CLoudManager? If that's the case, then what you are seeing is expected behavior.

    Regards,
    Vybhav

  • javileshsijavileshsi Member Posts: 5

    Hi @vybhavram

    I trying connet to AP by SSH after did the step 1 to 4 but I don´t have access to web I can´t upgrade the firmware to cloud manager

  • vybhavramvybhavram Xpert, Moderator Posts: 1,051

    Hello @javileshsi ,

    When you try and connect to the AP via SSH , are you able to see the prompt? Can you please try performing a factory reset of the AP (if the AP is not serving any clients) and check if your are still seeing this issue?

    Regards,
    Vybhav

  • ramonnramonn Member Posts: 4

    Good day,

    I'm trying to access via ssh my AP- Xo -1 , but the xclaim-mfg and mfg-admin12 and password do not work.

    Would have another password ?

  • Hi @ramonn,

    If the AP is managed through cloud AP password is encrypted.

    Thanks
    Ramesh

  • ramonnramonn Member Posts: 4

    Hi @rameshc,

    Yes the password is managed through the cloud , how do you figure out just the password now?

  • Hi @ramonn,

    Password is not configurable.

    Regards
    Ramesh

  • ramonnramonn Member Posts: 4

    @rameshc

    Sure, but I'd like to update the firmware via ssh to access to the web version. How will I do this , unable to access it?

  • Hi @ramonn,

    You can update the AP firmware either through the Cloudmanager ( UPGRADE button should light up when AP detects the new firware) or rebooting the AP twice in space of 5 minutes.

    Thanks
    Ramesh

Sign In or Register to comment.